Unconfirmed P3D Not Elevated

maxibk

New member
Hi guys,

Info for Bug Report:
- P3D 4.5
- Active Sky for P3D v4 plus Open Beta 7035 (6th April 2019)
- Reproduction of the problem is always possible in the moment when i start P3D 4.5. Have to click that message over 30 times away!


Since i updated to P3D 4.5 i donwloaded the Open Beta 7035.
After correct installation, when i start P3D 4.4 i get a very annoying message: P3D Not Elevated constantly until P3D 4.5 is up and running.

See screenshot: https://i.imgur.com/5VjqiC6.png

Even a complete reinstallation of the Active Sky for Prepar3D plus the Beta 7035 didn´t solve the problem. P3D Admin Rights are double checked!

The "funny" thing is, when P3D 4.5 is up and running the message dissapear?! :concern:

Any one other with this issue?

If you need any information, let mew know.

Thank you very much in advance!
 

maxam

Beta Team Member
Thank you for your post.

That message is by design as we have had customers who have had issues and submitted tickets only for us to find out they did not right-click on the Prepar3D.exe.

Hope this helps.
 

maxibk

New member
Hi Robert, thx for your quick reply.

I don´t wanna sound rude, have you read my post above ?
My P3D.exe is fully activated with admin rights, as i had done it over the last years. So sorry, this is a bug.
This is also the first time that i have this problem with Active Sky. Never happend before.
Take a look at the screenshot: https://i.imgur.com/NBFsJ9T.png

Any suggestions?

Thx in advance
 
Last edited:

maxam

Beta Team Member
Hello,

No problem, so what you are saying is that you do right-click and launch Prepar3D as administrator? It just isn't that clear, my apologies.

If that is the case I will have the developers look into this.

Thank you.
 
Last edited:

maxam

Beta Team Member
Hello,

Thank you, and you as well, please see my question above:

"so what you are saying is that you do right-click and launch Prepar3D as administrator?"
 

rsubers

New member
Just a nit pick. I understand P3D is set up to run elevated. While I realize this is currently required I suspect that it can be modified to not require this which would be desirable for computer security. I have been working in computer programming on Windows for a long time and the only programs I do that require elevation are installers which of course should require elevation. I guess please consider this an enhancement request.

BTW I also am getting the P3D is not elevated message.
 

damian

Developer
Staff member
Unable to reproduce any problem here. The message only shows when P3D is not elevated. Are you sure you re-applied the run as administrator flag for your application AFTER updating it? This is a new .exe when updating, so it will need to be applied again.

The requirement for elevation is based on the fact that our module needs write access for logging and other activities, within the P3D program files folder, which is not possible without elevation. We are working to move everything out of that location in the future but for now it must be here.

If you are continuing to get the message about run as administrator setting, please show a screenshot of the properties/advanced settings showing the "run as administrator" correctly checked for either your P3D icon or Prepar3D.exe file. Please also confirm that you are seeing the UAC prompt to run the P3D program accordingly. If not, is your UAC off? Please open a ticket at https://support.hifitechinc.com for any continued problems so we can collect more info as needed and address this as quickly as possible. Thank you!

EDIT: We did fix the recurring message when non-elevated P3D found and P3D takes longer than a few seconds to load and connect to ASP4. Will be in next build.
 

maxibk

New member
Hi Damian,

as in my posts above, I posted screenshots that the P3d.exe is permanently marked in the settings with full admin rights.
The step is also done AFTER the installation of the update to 4.5.
UAC is also off.
BTW: i know since Windows 10, if you are not marking or installing the install and .exe files, you get very strange oddities.
So i marked EVERY installer and .exe files with full admin rights.
And additionally i gave my windows administrator account, the "real" admin rights ;)
As i stated above, i had never the problems with Active Sky or P3D before.

Hope this Info helps.

Thank you for efforts to help us!

Regards
 

damian

Developer
Staff member
UAC is off and confirmed Administrator account... Then this sounds like a problem in the query process on the account. Maybe permissions/AV/security related. Could you please open a ticket at https://support.hifitechinc.com so we can confirm and resolve this? Thanks!
 

Daveo

Community Manager
Staff member

JDLinn

New member
I'm seeing this too, also it is telling me I need to get the update. I did get the update ... it still asks me for the update. I have P3D V4.4 (not 4.5). It all seems to work, but reminds me to run P3D as administrator and reminds me to get the update.
 
Top