Unconfirmed XP11.41 crashing

TheLurk

New member
hello, got ASXP yesterday and really like it, however i seem to be running into frequent and reproducable crashes with it on XP11.41 stable release.

attached are my xp11 log, aslog and the flightplan used in this scenario, departing EINN, i have xpilot installed but not in use at the time, i saw some posts about there being issues between the two so im not sure if this is related or not... i have filed a report with LR as well cause im not 100% certain where the issue lies

any help is apprecaited, thank you!

Tobias
 

Attachments

Last edited:

TheLurk

New member
update: tried a few flights without asxp and things are fine, soon as i enabled asxp after about 10 or so minutes the sim crashes. updated logfile attached.
 

Attachments

TheLurk

New member
ive done some more testing, it appears everything is working just fine when xplane and asxp run on the same machine, i usually am running a networked setup with a second machine connected via ethernet cable, previously on fsx/p3d this worked fine, is it possible there is an issue with my network setup or the way asxp handles that?
 

maxam

Beta Team Member
Hello,

It could be firewall settings, be sure to allow program access (incoming & outgoing) on both computers. Also be sure to exclude ASXP and X-Plane from being scanned by antivirus and/or Windows Defender. Lastly ensure that all the folders are properly shared and permissions applied.

Security and Permissions

Network, connectivity or performance issues may be caused by firewall and antivirus settings, exclusions and permissions may reduce these occurrences.

Antivirus:
Antivirus may cause performance and connectivity issues. Consumer programs including Microsoft Security Essentials (Windows 7) and Windows Defender (Windows 10) may interfere with operation of programs. The X-Plane and Active Sky Installation folders must be added to your excluded or allowed list to prevent any file scanning.

Under Excluded files and Locations add the following folder locations that apply:

Your Drive Letter:\Program Files (x86)\HiFi\ASXP\
Your Drive Letter:\Users\User Name\AppData\Roaming\HiFi\AS_XPL\
Your Drive Letter:\X-Plane 11\

Several antivirus software packages DO NOT actually stop scanning/blocking software even when disabled, especially under Windows 10. In many cases, adding an exclusion will resolve the issue. Also, be sure to update an existing firewall inbound/outbound rule after an update of Active Sky because the program executable has been changed.

Sharing:
Network Configuration, please ensure the following including X-Plane 11 main installation folder are properly shared.

The path is:

• Simulator PC (server) - The X-Plane main installation path (for example: C:\Program Files\X-Plane 11 = default share name: X-Plane 11)

You may also have to change permission to allow proper flow of data. Adding "Everyone" in the security tab of each folder may help.

To give permission to the folder:
- Right click the folder you want to set the access permissions for and then select Properties.
- In the properties window click on the Security tab then click on Edit.
- On the Permissions window click on the Add button to open the Select Users Group or Groups window.
- On the Select Users or Groups window you can enter the usernames i.e., Everyone.
- Then, click OK.
- Select Full Control by placing a check mark on “Allow”
- Apply the settings.
- Close the properties window.

In rare cases the issue may only be resolved by disabling Windows Defender and other antivirus and performing an uninstall/reinstall of ASXP.
 

TheLurk

New member
thanks for the reply, i'll double check my network setup but it should be fine since i use it for p3d as well and have been for years, the drives etc. have not changed, just the simulators, which is why its so baffling to me but i will go over things just to make sure.

i have done multiple flights now with xp11 and asxp on the same machine without issues, soon as i launch it on the networked machine it crashes after roughly 10 or so minutes.

also with that in mind, would switching the local ip used be worth a shot? right now i have the direct connection selected, i could try and set the router ip and have it go that way if you think that might make a difference?

cheers
Tobias
 

maxam

Beta Team Member
Hello Tobias,

The AS_Log.txt shows a connection with ASXP & X-Plane via the network which is good. As you may have noticed networking X-Plane is a much simpler process compared to the sims that use Microsof Simconnect (FSX, FSX:SE and Prepar3D). With ASP3D Connector the networking has become as easy as it is with X-Plane.

There is no other way to find out but try your idea about switching the local IP. If X-Plane does crash again it may be worth looking at the Windows Event Viewer "Custom Views-Administrative Events" and "Windows Logs-Application" to see what the error description may provide for an answer.

Also, please remove the X-Pilot plugin from the X-Plane installation to see if that may be causing an issue.
 

TheLurk

New member
hello, sure i'll try those, in the meantime here are the eventviewer reports for my previous crashes

the application error itself
Code:
Faulting application name: X-Plane.exe, version: 11.0.41.0, time stamp: 0x5de8048a
Faulting module name: unknown, version: 0.0.0.0, time stamp: 0x00000000
Exception code: 0xc0000005
Fault offset: 0x0000000085d67ffc
Faulting process id: 0x66c
Faulting application start time: 0x01d6585138d0bb7f
Faulting application path: D:\Games\steamapps\common\X-Plane 11\X-Plane.exe
Faulting module path: unknown
Report Id: e929ab07-cbb4-481e-8431-3930bc65f291
Faulting package full name:
Faulting package-relative application ID:

and the windows error reporting dump:
Fault bucket 2208415057171991389, type 5
Event Name: BEX64
Response: Not available
Cab Id: 0

Problem signature:
P1: X-Plane.exe
P2: 11.0.41.0
P3: 5de8048a
P4: StackHash_2264
P5: 0.0.0.0
P6: 00000000
P7: PCH_7C_FROM_unknown+0x0000000000000000
P8: c0000005
P9: 0000000000000008
P10:

Attached files:
\\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WER2663.tmp.dmp
\\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WER2F0F.tmp.WERInternalMetadata.xml
\\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WER2F3F.tmp.xml
\\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WER2F3D.tmp.csv
\\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WER2F6D.tmp.txt

These files may be available here:
\\?\C:\ProgramData\Microsoft\Windows\WER\ReportArchive\AppCrash_X-Plane.exe_eb89d4d504a49508211caecd28d6eaf1692f4_cdc52aa6_f3b2d48b-3851-4d8e-853f-390730443e16

Analysis symbol:
Rechecking for solution: 0
Report Id: e929ab07-cbb4-481e-8431-3930bc65f291
Report Status: 268435456
Hashed bucket: 4aabbb16c1aecb7a4ea5ddcb375c4b5d
Cab Guid: 0
i will report back on further testing.
 

maxam

Beta Team Member
Looking over your X-Plane log, I see that a crash occurred with the TBM900.

2020-07-12 14:59:27 TBM900[except.c:171]: Caught EXCEPTION_ACCESS_VIOLATION
2020-07-12 14:59:27 TBM900[except.c:171]: Caught EXCEPTION_ACCESS_VIOLATION

See if removing the plugin resolves the issue.
 

TheLurk

New member
update; latest crash log attached, not using the TBM, using a different IP, crash. next im gonna remove xpilot temporarily and test.
 

Attachments

TheLurk

New member
and here is the next one, without x-pilot loaded, same ip used as above. also the windows dump this time....

just to reiterate this _ONLY_ happens when using asxp on a different machine via the network. local is fine.

Code:
Faulting application name: X-Plane.exe, version: 11.0.41.0, time stamp: 0x5de8048a
Faulting module name: win.xpl, version: 0.0.0.0, time stamp: 0x5e793ab2
Exception code: 0xc0000005
Fault offset: 0x000000000010d0e8
Faulting process id: 0x4a30
Faulting application start time: 0x01d65abd34ec17ca
Faulting application path: D:\Games\steamapps\common\X-Plane 11\X-Plane.exe
Faulting module path: D:\Games\steamapps\common\X-Plane 11\Resources\plugins\DataRefTool_2020_03_23\win.xpl
Report Id: b4eb9ae4-c3c5-4d04-af78-696ca0e138ef
Faulting package full name:
Faulting package-relative application ID:

Code:
Fault bucket 1391846205953071673, type 5
Event Name: BEX64
Response: Not available
Cab Id: 0

Problem signature:
P1: X-Plane.exe
P2: 11.0.41.0
P3: 5de8048a
P4: win.xpl
P5: 0.0.0.0
P6: 5e793ab2
P7: 000000000010d0e8
P8: c0000005
P9: 0000000000000008
P10:

Attached files:
\\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WERF8C6.tmp.dmp
\\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WERFAEA.tmp.WERInternalMetadata.xml
\\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WERFB1A.tmp.xml
\\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WERFB27.tmp.csv
\\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WERFB57.tmp.txt

These files may be available here:
\\?\C:\ProgramData\Microsoft\Windows\WER\ReportArchive\AppCrash_X-Plane.exe_7a27ef95f34efe03055e6f2a16d8e63798542c_cdc52aa6_dd028a10-fc1f-482d-a4af-ae6c81ca77cc

Analysis symbol:
Rechecking for solution: 0
Report Id: b4eb9ae4-c3c5-4d04-af78-696ca0e138ef
Report Status: 268566528
Hashed bucket: 7ccecf2ab98d52728350d4bfffceda39
Cab Guid: 0
 

Attachments

maxam

Beta Team Member
Hello,

There seems to be many CTD's attributed to the BEX64 issue that has plagued X-Plane users, even on vanilla installations. Interesting how you do not have a CTD when using locally yet the network install causes a CTD.
 

TheLurk

New member
yeah, i have filed a bugreport with laminar themselfs but havent gotten anything back from them yet, im just as confused as you are by it... i mean for what its worth i could try an absolutely clean installation with nothing in it...
 

maxam

Beta Team Member
Your X-Plane license does allow for a second installation, you can create a vanilla testing version for yourself.
 

TheLurk

New member
interesting, i do have the steam version of x-plane, i need to look into how i would install it a second time... i'll get to that.
 

TheLurk

New member
i tried with a clean installation, no plugins whatsoever loaded outside of the asxp one, crash still happens. same addresses and calls as before :/
 
Top